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A) Basic Information on Joomla Templates- top 

This introductory tutorial will give you an insight into the Joomla! templating system and 
what you can do with it. 

Purpose of templates 

A template controls the overall look and layout of a site. It provides the framework that 
brings together common elements, modules and components as well as providing the 
cascading style sheet for the site. Both the front-end and the back-end of the site have 
templates. 

When Joomla! is first installed several templates are automatically included. You can find 
many more templates at other websites. Some are available without charge under various 
licenses, and some are for sale. In addition, there are many developers available who can 
make custom templates. You can also make your own template. 

Templates are managed with the Template Manager, which is located on the Extensions 
menu in the back-end (administrator) area of your site. 

Why does Joomla! use templates? [A real beginners guide!] 

mailto:youremail@yourdomain.com
http://themeforest.net/user/wisdomtheme


The way Joomla! is designed separates out the key tasks involved in producing a website for 
efficient maintenance of the software. One of these tasks is to create the aesthetic (the look, 
feel and layout) of the site. This includes making decisions such as which content elements 
(components, modules and plugins) you may want to place in any given page. 

When producing a web page, the location of most elements will stay the same (menus, 
banner locations, sidebars etc.). Additionally, you will want to create the same look (fonts, 
header styles, colour scheme etc.) for every page. For some parts of the site you may want 
to alter the general feel to indicate a different purpose for those pages (such as a blog 
section). A little planning is required for this, but once you have settled on the overall layout 
for your site, you then have the task of producing each page of content. 

And that’s where the template comes in. You can either write all the code for each page 
separately, or use a template for each major section of your site so that when you want to 
create a new page you simply “fill in the blanks”. Okay, perhaps it's not that simple, but this 
tutorial is designed to give you a step by step guide for effective template use, starting with 
how to use one and ending with how to create one for yourself. 

1. Use one of the templates supplied with Joomla! 
2. Download one of the many free offerings from the Internet. 
3. Pay for one to be modified or produced from scratch if your needs cannot be met any 

other way. 

Summary – a template controls the look of your site and at the same time allows the 
website administrator focus more on the actual content. 

What can you do 

A template is used to manipulate the way content is delivered to a web browser or screen 
reader. Here are some ways you can employ this on your Joomla!-powered site. 

Layout 

The template is the place where the design of the main layout is set for your site. This 
includes where you place different elements (modules). For example: You can control the 
placement of menus, a log in form, advertising banners, polls, etc. 

https://docs.joomla.org/Module


 

Note the changes in content layout! 

The main body(article) of the page can be altered in style(you can select from different styles 
of display such as typical blog layout, a news article, etc) depending on the templates layout. 
*See the example image. Note the differences in layout, but how the look is consistent. The 
sidebar of modules has been moved from left to right and its order rearranged. 

If the template is designed to provide choices, you can also "dynamically" alter the content 
placement on your site, perhaps putting the main menu on the right or left side of the 
screen. 

Color Scheme 

Using CSS within the template design, you can change the colors of your backgrounds, text, 
links or just about anything that you could within your ordinary HTML code. Some templates 

https://docs.joomla.org/File:J3x-template-example-module-changes-screenshot.png
https://docs.joomla.org/Article


provide a method to change the color in template management, others require you to 
modify the template's .css file(s). 

Images and Effects 

You can also control the way images are displayed on the page, and even create flash-like 
effects or include AJAX applications such as drop-down menus. 

Fonts 

The same applies to fonts. The designs for these are all set within the template's CSS file(s) 
to create a uniform look across your entire site, which makes it fantastically easy to change 
the whole look just by altering one or two files rather than every single page. 

Browser Specific Solutions 

A template can be designed to alter how it displays on different web browsers, allowing you 
to take full advantage of the latest developments without making your site inaccessible to 
those who are not able to run "up-to-the-minute" system upgrades (such as certain 
companies who limit what software their employees can use). 

Templates Supplied 

The following templates are supplied with a default installation of Joomla! 3.x 

Site Templates 

 Protostar (Default template) 
 Beez 3 

Administrator Templates 

 ISIS (Default template) 
 Hathor 

Switching Templates 

To change the default Template for the Site (Front-end) or Administrator (Back-end), follow 
these steps: 

Access the template manager 

 Log in to the Administrator (Backend). If you are not sure how to do this see: To log in 
to the Administrator (Backend) 

 Click on: Extensions → Templates 

http://en.wikipedia.org/wiki/AJAX
https://docs.joomla.org/Special:MyLanguage/J3.1:Logging_in_or_out_of_the_Administrator_back-end
https://docs.joomla.org/Special:MyLanguage/J3.1:Logging_in_or_out_of_the_Administrator_back-end


 

You will now see the Template Manager screen. 

Note: If you do not see Templates listed as an option on the Extensions menu, then it is 
most likely because you are not logged in as a Super Administrator. Only Super 
Administrators will see this menu item. 

Managing default template 

From here you manage your templates for Front-end and Back-end. The default view shows 
your installed Front-end templates styles. The default style for the Front-end is marked with 
a star; in the image below it is protostar - Default. 

To change the default style to beez3: 

 click the checkbox left from the style name to select it; 
 click "Default" on the toolbar; 

the star changes from protostar to beez3 and you are done. Alternatively, you can click on 
the shadow of a template's default star to quickly set the template as default. 

You can use the filter drop downs on the left or the filter search to limit the number of 
templates shown in the list of templates. Other options are: 

 edit - edit the pages a template is shown on (see below) 
 delete - delete a template (must not be default template) 
 options - set options for templates 

 

 

https://docs.joomla.org/File:Extension-manager-template-manager-3x-en.png
https://docs.joomla.org/File:30-Switching-templates-1-en.png


Assigning more than one template for the Front-end 

Joomla! gives you the option of switching between two or more styles on the Front-end. This 
is done with "Menu Assignment", so you can set different styles for each menu or only a 
menu item. This allows specific "pages" that are defined by menu links to set for a "specific" 
style. Styles can be of different templates. 

Template manager method 

Click on: Extensions → Template Manager 

 You will see your installed template styles, now choose a style which is not set as 
your default one. Yellow star indicates the style is a default. 

 

 Click on the style name or hit the checkbox to the left of the style name, and click 
"Edit" on the toolbar. 

 You now see the page "Template: [ Edit style] ", and go to the section "Menu 
Assignment" block and choose the menu items on which the style should be shown. 

https://docs.joomla.org/File:30-Template-manager-select-edit-en.png


 

 Click "Save" on the toolbar and you´re done. The menu item will now show the 
selected template. 

 Go to the front-end of your website and refresh the page to view the modifications. 

Menu manager method 

 Access menu item Menus → Menu Name 
 Choose a menu item by checking the box to the left of its name and then click on the 

Edit toolbar button. Alternatively, simply click the name of the menu item to edit it. 
 On the Edit Menu Item screen, in Template Style, choose the desired template style 

and click on the Save button. 

https://docs.joomla.org/File:30-Switching-templates-assign-menus-en.png


 

 Go to the frontend of your website and refresh the page to view the modifications. 

Installing a template 

Install via Admin Panel (packed template file) 

Log into the back-end of your site (www.your-site.com/administrator/) 

Click on: Extensions -> Extension Manager 

 

https://docs.joomla.org/File:30-Menu-item-template-management-edit-en.png
https://docs.joomla.org/File:30-Installing-template-navigate.png


You see the page "Extension Manager" 

From here you can install your Templates, Plugins, Modules, Components and Languages. 
You have three options: 

1. Install from Web - (select an extension listed on the Joomla! Extension Directory) 
2. Upload Package File - (select a package from your PC, upload and install it) 
3. Install from Directory - (enter the path where the package is located on your 

webserver) 
4. Install from URL - (enter the URL to the package) 

Option 4 does everything for you, your environment needs to be properly configured to 
allow this. Option 2 requires you to download the extension to your PC. Option 3 requires 
you to unzip and move the folders/files to your webserver. All options require the webserver 
to have write access to the webspace. 

Here, we choose the second method: Upload Package File 

Select the package from your PC and click the button "Upload File & Install" 

 

 
If the package contains no errors you are done and get a success message like the one 
below. 

https://docs.joomla.org/File:30-Installing-template-upload-package-file-en.png


 

Verify installation 

Go from tab 'Install' to tab 'Manage', set the 'Type' filter to 'Template'. The installed 
template should appear in the list. If it does, the template is properly installed. Now you can 
assign one of styles to a menu item or set the style as default. For administrator templates 
make sure you have two windows of the template manager. Activate the new template in 
one of them and reset it in the other one if something went wrong. 

Install via FTP (unpacked template file) 

Templates can also be installed via FTP without packaging them. Simply select the template 
folder on your PC and upload it to your server, using your favourite FTP software. Be sure 
you upload the template folder to the directory: /path_to_joomla/templates/ - where 
/path_to_joomla/ is the location of your Joomla! installation on the server. This method is 
mostly used when you have created a template yourself, and do not want to have to 
package it to install the template, or if you want to upload more than one template at once. 
You must then go into extension manager and click on Discover in the sub menu. Click on 
"Discover" in the toolbar if your template doesn't immediately appear. A list of uninstalled 
items in the FTP should then appear. Click the checkbox to the left of your template and click 
on the button 'Install'. 

Note: Do not try to use FTP to install Components, Modules and Plugins if you are a 
beginner/novice. These items need database entries which have to be inserted manually if 
you bypass the package installer. 

 

Modifying a Joomla! Template 

Templates are just a group of XML, PHP, HTML and image files that are stored in the 
templates directory of your site. You can edit these files directly or use the Template 
Manager.  

Before You Begin 

Before you start hacking away at a default installed template or any other template you may 
have installed, remember that any updates of the Joomla core files may contain new copies 
of the default Joomla templates. Similarly, editing an installed template means you may have 
to re-install it to reset it to the original state at installation.  

https://docs.joomla.org/File:30-Installing-template-install-success.png


Unless you take steps to protect your work, modifications could be lost when upgrading 
Joomla. Likewise, you may want to preserve an installed template in case you have any 
problems with modifications to it.  

There are options in the Template Manager to Duplicate and Copy an existing template style 
or the actual template and template files. This page refers to the methods available to make 
a full copy of your template. This includes the style and all the template files of a template.  

A Tip! 

Template Style and Template copying are not the same. You can make a copy of the 
template style but you are not protected from overwriting the actual template files. Style 
copying simply adds another entry made in the _template_styles table of the database. This 
is useful is you want to check a web site design with different fonts, colors, widths or logos if 
these template style parameters exist. The template files are not duplicated into another 
uniquely-named directory and they will be overwritten during an upgrade. 

Copy the Template 

To preserve your changes you need to Copy the template with all its files and styles. This 
procedure makes references to creating a full copy (an exact duplicate) of the template 
including all the files. In order to make a copy, you must be on the Customise Template 
view.  

There are two methods available for accessing the Template Manager: Customise Template. 
The Customise Template interface allows for editing the actual code found in the template 
files, creating template overrides and template file manipulation.  

https://docs.joomla.org/Special:MyLanguage/J3.x:To_access_the_Template_Manager
https://docs.joomla.org/J3.x:How_to_use_the_Template_Manager


One-Click or Switch to Template View 

 

A Tip! 

Styles column refers to changing the available parameters of a template, such as color, font-
color, logo, etc. These are dependent on the parameters a template maker made available 
and are a convenience for quick changes. Template - column refers to editing the actual 
template files. 

To access the Template Customise feature:  

 Directly - Click the template name in the column Template  

https://docs.joomla.org/File:30-Template-manager-template-styles-view-1-en.png


 

 Indirectly - Styles will be highlighted, click on Templates below it which will turn the 
view to Template Manager:Templates, see image below.  

 

 Select the template you wish to modify which will change the view to 
Template Manager: Customise Template view  

Customisation View 

You should now be looking at the image below, Template Manager: Customise Template.  

https://docs.joomla.org/File:30-Template-manager-template-styles-view-2-en.png
https://docs.joomla.org/File:30-Template-manager-template-style-view-en.png
https://docs.joomla.org/J3.x:How_to_use_the_Template_Manager


 

 

Copy an Existing Template 

The Easy Way 

Create a new template by copying an existing template:  

 Click on Copy Template in Toolbar in Template Manager: Customise Template view.  

 

 Provide a new name and click on Copy Template  

 

 The template is completely copied. This includes styles and all the template files.  

https://docs.joomla.org/File:3x-template-manager-customise-template-en.png
https://docs.joomla.org/Special:MyLanguage/J3.2:How_to_use_the_Template_Manager
https://docs.joomla.org/File:3x-template-manager-customise-template-toolbar-en.png
https://docs.joomla.org/File:3x-template-manager-customise-template-popup-copy-en.png


Manually 

 Create a new /templates/my_template directory.  
 Copy the contents of the original template directory to the my_template directory.  
 Go to the root /language/en-GB directory.  

o Copy /language/en-GB/en-GB.tpl_original_template.ini to en-
GB.tpl_my_template.ini  

o Copy /language/en-GB/en-GB.tpl_original_template.sys.ini to en-
GB.tpl_my_template.sys.ini  

 Go to the /language/en-GB directory in the template's directory, if it exists.  
o Copy /language/en-GB/en-GB.tpl_original_template.ini to en-

GB.tpl_my_template.ini  
o Copy /language/en-GB/en-GB.tpl_original_template.sys.ini to en-

GB.tpl_my_template.sys.ini  
 Open the templateDetails.xml file in the my_template directory and change all 

references, if they exist, for the original template directory to the new directory 
my_template.  

<name>My_Template</name> 
<language tag="en-GB">en-GB.tpl_my_template.ini</language> 
<language tag="en-GB">en-GB.tpl_my_template.sys.ini</language> 
<param name="template_header" type="folderlist" 
directory="templates/my_template/styles/header" default="" label="Header Templates" 
description="HEADER TEMPLATES DESCRIPTION" /> 
<param name="template_background" type="folderlist" 
directory="templates/my_template/styles/background" default="" label="Background 
Templates" description="BACKGROUND TEMPLATES DESCRIPTION" /> 
<param name="template_elements" type="folderlist" 
directory="templates/my_template/styles/elements" default="" label="Primary Elements" 
description="PRIMARY ELEMENTS DESCRIPTION" /> 

Discover the New Template 

When manually copying a template, the new template must be introduced to your Joomla 
site through the discovery process.  

 Go to Administrator → Extensions → Extension Manager → Discover  
 Click the Discover icon.  
 Select your new template.  
 Click Install.  

If successful, the new template will now be available in 
Administrator → Extensions → Template Manager  

 Make the new template the default template.  
 View the site to verify it.  

Finding Errors 



You might have problems as a result of copying an existing template to a new template. 
Because of the way that Joomla handles file names, you might be tripped up by a 
capitalization error, for example.  

Joomla contains some useful debugging tools. To see what is happening while working on a 
site, there are three settings that you should change.  

1. Administration > Site > Global Configuration > System > Debug Settings > Debug 
System > Yes (Default = No)  

2. Administration > Site > Global Configuration > System > Debug Settings > Debug 
Language > Yes (Default = No)  

3. Administration > Site > Global Configuration > Server > Server Settings > Error 
Reporting > Maximum (Default = System Default)  

With the Debug Language set to Yes, for instance, you will see the success or failure of 
language file loading on each page of the Administrator. Open the Joomla Debug Console > 
Language Files Loaded panel to view the report.  

 

(Note: The information above is taken From Joomla! Documentation) 
 
(Note: The information above is taken From Joomla! Documentation) 
 

 

B) Wisadmin Template Files Structure - top 

Wisadmin Template (Zipped package) consists of the folders and files below: 
 
-CSS files within css folder 
-Html folder 
-Images folder 
-Js folder containing jquery.js and other Javascript files 
-Language files within Language folder 
-component.php 
-cpanel.php 
-favicon.ico 
-index.php 
-login.php 
-Template_preview.png 
-Template_thumbnail.png 
-TemplateDetails.xml 
 
 
Attention: You need not to work on this files unless customizing module core files needed. 
You should upload and install the zipped package as mentioned below. 



 

C) Installation Guide and Template Parameters - top 

Installing a template 

Install via Admin Panel (packed template file) 

Log into the back-end of your site (www.your-site.com/administrator/) 

Click on: Extensions -> Extension Manager 

 

You see the page "Extension Manager" 

From here you can install your Templates, Plugins, Modules, Components and Languages. 
You have three options: 

5. Install from Web - (select an extension listed on the Joomla! Extension Directory) 
6. Upload Package File - (select a package from your PC, upload and install it) 
7. Install from Directory - (enter the path where the package is located on your 

webserver) 
8. Install from URL - (enter the URL to the package) 

Option 4 does everything for you, your environment needs to be properly configured to 
allow this. Option 2 requires you to download the extension to your PC. Option 3 requires 
you to unzip and move the folders/files to your webserver. All options require the webserver 
to have write access to the webspace. 

Here, we choose the second method: Upload Package File 

Select the zipped wisadmin template package  from your PC and click the button "Upload 
File & Install" (Please Note that you should Unzip whole package first and then select the 
zipped template file) 

https://docs.joomla.org/File:30-Installing-template-navigate.png


 

 
If the package contains no errors you are done and get a success message like the one 
below. 

 

Verify installation 

Go from tab 'Install' to tab 'Manage', set the 'Type' filter to 'Template'. The installed 
template should appear in the list. If it does, the template is properly installed. Now you can 
assign one of styles to a menu item or set the style as default. For administrator templates 
make sure you have two windows of the template manager. Activate the new template in 
one of them and reset it in the other one if something went wrong. 

Install via FTP (unpacked template file) 

Templates can also be installed via FTP without packaging them. Simply select the template 
folder on your PC and upload it to your server, using your favourite FTP software. Be sure 
you upload the template folder to the directory: /path_to_joomla/templates/ - where 
/path_to_joomla/ is the location of your Joomla! installation on the server. This method is 
mostly used when you have created a template yourself, and do not want to have to 
package it to install the template, or if you want to upload more than one template at once. 
You must then go into extension manager and click on Discover in the sub menu. Click on 
"Discover" in the toolbar if your template doesn't immediately appear. A list of uninstalled 

https://docs.joomla.org/File:30-Installing-template-upload-package-file-en.png
https://docs.joomla.org/File:30-Installing-template-install-success.png


items in the FTP should then appear. Click the checkbox to the left of your template and click 
on the button 'Install'. 

Note: Do not try to use FTP to install Components, Modules and Plugins if you are a 
beginner/novice. These items need database entries which have to be inserted manually if 
you bypass the package installer. 

Wisadmin Template Parameters 

Template Color Scheme: Select Template Color Scheme. Default color style is Blue. You can 
choose one of  7 colors.  
 

 
 
 
 
Base Font Size: Select Base Font Size for administration area and then click save button. 
 



 
 
 
Header Font Size: Select Font Size for Headers on admin area. 

 

 
 
 
Author Image: Select Author Image to be displayed. It should be in images files of main site. 
If no image selected the default author image in wisadmin/images file will be displayed. 
 



 
 
Show Name or Username: Show author's real Name or Username on top right. 
 

 
 
Select Google Fonts  : Select Google Fonts for admin area. 
 



 
 
 
 
Logo  : Upload a custom logo for the administrator template. 
 
 

 
 
Login Logo  : Select or upload a custom logo for the login area of administrator template. 
 

 



 
 
Collapse Administrator Menu:  If you intend to use Joomla Administrator on a monitor, set 
this to 'No'. It will prevent the collapse of the Administrator menus when reducing the width 
of the window. Default is 'Yes'. 
 

 
 
Display Header :   Optional display of header. 
 

 
 
Show Status Module   :  Show / Hide the status module at the bottom. 



 

 
 
Pinned Toolbar   :  Optionally set the menu toolbar to a fixed (pinned) location when scrolled 
down. 
 

 
 
 
 
Show Welcome Message : Show or Hide  Welcome Message on login page above username 
and password area. 
 
 



 
 
 
Welcome Message : Enter a Welcome Message on login page above username and 
password area. 
 

 
Select Login Interface  : Select Login Interface there are 5 login interfaces 
 



 
 
 
 
Bottom Icon Alt Text   : Alt Text for little Bottom Icon on Login Page  when mouse over  
 

 

 
 
 

 

D) Additional Information and  Support Forum - top   



Thankyou for choosing us. You can use our support forum for further information.  

http://www.JoomlaTema.Net/forum.html 

 

 

E) Sources and Credits - top 

I've used the following images, icons or other files as listed.  

 Icons from iconfinder.com 
 Images from freegreatpictures.com 
 Tutorials  from docs.joomla.org 

 

Once again, thank you so much for purchasing this theme. As I said at the beginning, I'd be 
glad to help you if you have any questions relating to this theme. No guarantees, but I'll do 
my best to assist. If you have a more general question relating to the themes on 
ThemeForest, you might consider visiting the forums and asking your question in the "Item 
Discussion" section. 

WisdomTheme 

Go To Table of Contents 
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